澳门新莆京免费网址欢迎您

澳门新莆京 1
澳门新莆京2019年1-11月通信业经济运行情况

上交所首批信用保护凭证落地 助力发行人债券融资顺利进行

文言文编程语言来了 可是好像比英文更难写了

原标题:噫吁嚱,文言文亦能编制程序热以口合FY之SG&L&Aljmmmp>pj*fSS示coMzSezC>u=$>*OTvplEeEUoj>#seLsHJ!esssJSX>SS*%X>Y%JG>XsHJSm”
img-code=”0″/>]article_澳门新莆京免费网址欢迎您,adlist–>图片来源于@unsplash]article_adlist–>钛媒体注:本文来源于Wechat民众号量子位(ID:QbitAI),作者为栗子、晓查,钛媒体经授权发布。]article_adlist–>文言文]article_adlist–>输出“Hello
World”?请君睁圆双目注视于此:△ 侧面一顿输出吾有一言。曰「「問天地幸好。」」。書之。却为啥输出了一遍?只因有for循环,写作“為是「甲」遍…云云”。甲等于三,便要问一回好。那骚之过极的文言文编制程序语言,来自CMU本科生Huang
Lingdong。可编写翻译成Javascript,也可编写翻译成Python,亦有线上编写制定器 (IDE)可一贯玩耍。项目文科理科两开花,已于GitHub摘得3000星,且围观大伙儿皆有话说。举个例子,妒少年之才华:比如,点今后之大势:中国中国科学技术大学学计算所商讨员刘群先生亦咋舌:当下,小编等便前去观膜一番,探究此语言藏有什么种天土精髓。文言文编制程序“黑话”Huang
Lingdong同学应该是读过《易经》,究竟易经是最初论述二进制的古书。他用易经的阴和阳代表布尔变量中的0和1。“吾有”种类则被用来做定义:吾有一数是定义int变量;吾有一爻是概念布尔变量;吾有一言是概念字符串;吾有一术是概念函数;吾有一列是概念数组;……平日的编制程序里,循环决断有if、while、for,文言文编制程序在此件事上尤其变化莫测。上面正是一段文言文书写的论断语句:若三弗大於五者。乃得「「想當然耳」」。若非。乃得「「怪哉」」也。翻译过来就是:if(3<=5卡塔尔国  {return “of course”}else  {return “no way”}恐怕你会以为if…else…语句用文言文太啰嗦,可是常用的for循环,用文言文表明却特别轻便。為是百遍。⋯⋯
云云。它的意思是:for (var i = 0; i < 100; i++卡塔尔(قطر‎  { … }假诺急需看清有些变量human是还是不是在world中,大家日常用for
(var human of
world卡塔尔,初读书人看来for的这种用法可能会很郁结,而文言文的象征更就如一般人的掌握。凡「天地」中之「人」。⋯⋯
云云。古有《易经》,今有金大侠小说,在彰显定义函数的时候,Huang同学又皮了须臾间:吾有一術。名之曰「六脈神劍」。欲行是術。必先得六數。曰「甲」。曰「乙」。曰「丙」。曰「丁」。曰「戊」。曰「己」乃行是術曰。⋯⋯是謂「六脈神劍」之術也。这里Huang同学将函数名定义为“段氏身法”,那些函数总共有6个输入。funcion f(a,b,c,d,e,fState of Qatar  {…}还应该有更加多有意思的函数定义:怎么着用文言文编制程序看完文言文编制程序的着力语法后,我们来探视怎么用它来缓慢解决一些为主的问题。例如求100以内的素数,我们会用到一种“埃氏筛”(Sieve
of
Eratosthenes)算法:看一下运营结果:二。三。五。七。一十九。一十二。一十三。一十八。五十九。三十六。五十六。五十六。六十三。二十七。三十九。二十九。七十四。二十五。五十八。二十七。二十七。七十七。七十四。八十四。七十一您看懂是什么看头了吧?编写翻译器翻译成JavaScript正是:var AI1SHI4SHAI1 = (State of Qatar => 0;AI1SHI4SHAI1 = function(JIA3卡塔尔 {    var YAN3 = [];    for (var _rand4 = 0; _rand4 < JIA3; _rand4++) {        YAN3.push(true);    };    var _ans154 = JIA3 / 2;    var JIA3BAN4 = _ans154;    var WU4 = 2;    while (true) {        if (WU4 == JIA3BAN4) {            break;        };        var XU1_ = 2;        while (true) {            if (XU1_ == JIA3BAN4) {                break;            };            var _ans155 = WU4 * XU1_;            var HE2 = _ans155;            if (HE2 <= JIA3) {                YAN3[HE2 – 1] = false;            } else {                break;            };            var _ans156 = 1 + XU1_;            XU1_ = _ans156;        };        var _ans157 = 1 + WU4;        WU4 = _ans157;    };    var ZHU1SU4 = [];    var WU4 = 2;    while (true) {        if (WU4 == YAN3.length) {            break;        };        var _ans158 = YAN3[WU4 – 1];        var SU4YE2 = _ans158;        if (SU4YE2) {            ZHU1SU4.push(WU4);        };        var _ans159 = 1 + WU4;        WU4 = _ans159;    };    return ZHU1SU4};var _ans160 = AI1SHI4SHAI1(100);console.log(_ans160卡塔尔国;文言文编制程序不只能出口轻便的结果,连文字图(ASCII
阿特)都足以用文言文画出来,分形难题中有名的“曼德博集结”,用中文画出来是那般:△用中文画出的曼德博集合你以为那就是编写翻译结果的末尾形象了?错错错!项目文件还应该有个脚本src/render.js,它能够把程序渲染成东魏图书的样子。把O’Reilly体系图书印制作而成清朝线装书,真是思维就很感动啊。何出此“言”至于,为啥要制作一门文言编制程序语言,少年为项目写有一序,由此可窥一二
(后有解读卡塔尔:夫唐、虞之世,結繩而足治,屈指而足算。是時豈料百代之後,計算機械之巧,精於公輸之木鳶,善於武侯之流馬;程式語言之多,繁若《天官》之星宿,奇勝《山經》之走獸。鼠、蟹、鑽、魚,或以速稱。蛇、象、駱、犀,各爭文采。方知鬼之所以夜哭,天之所以雨粟。然以文言編程者
,似所未有。此誠非文脈之所以傳,文心之所以保。嗟予小子,遂有斯志。然則數寸之烏絲猶覆於頭,萬卷之素書未破於手;一身長羁于远邦,兩耳久旷于雅言。然夫著小编吾之所宿好,程式者偶承時人之謬譽。故希孟不慚年少,莊生不望無涯。乃作斯言。誠未能嘔瀝長吉之心血,亦庶幾免於義山之流沫。既成之後,復學干將鑄劍而自飼,越王嚐糞而當先。自謂偶追《十書》之筆意,但恨少八家之淋漓。此子山所謂士衡抚掌而愿意,平子見陋而固宜。然則雖實覆甕之質,尚存斧正之望;雖乏呂相之金,易字之渴蓋同。此亦開源之大義,吾輩之所以勉勵也。一笑。文中故事之多,恐不可能在这里一一注释,便以划入眼之法,粗粗掌握其代表,并简短传达为白话:上古时候的人类结绳记事,不会想到后代竟然发明了计算机。几近些日子编制程序语言众星闪耀,只是未有人用文言编制程序。小编人在海外,驰念这个古典的开口,同期又擅长编制程序又有毛发,决定为开源职业进献一份力量。量子位循一望可知,得悉少年名为Huang Lingdong,来自卡耐基梅隆高校,近来大四,二〇一七年就要毕业。高级中学生守则毕业自东方之珠世界国外语中学。黄姓少年一路脑洞盛开,时常开辟画风清奇之项目,量子位也曾为其另一品类撰文:任君随意涂画,皆可化作梦境中之剧中人物,生机勃勃,与其余人选一起嬉戏游荡。如百鬼夜行之雄风。而文言文编制程序语言,大概是少年于今最佳自豪且最为瞩目之产生。各位可速速前往吸之,定然不恐怕自拔。
越来越多精粹内容,关切钛媒体微非确定性信号(ID:taimeiti),可能下载钛媒体App]article_adlist–>
]article_adlist–>

澳门新莆京免费网址欢迎您 1

原标题:文言文编程语言来了 但是好像比泰语更难写了
来源:开源中国新近有开垦者开源了一门新的编制程序语言,吸引了汪洋开辟者的目光,短短几天得到了
3k+
star。该语言名称叫“文言(wenyan-lang)”,那是一门采取文言文输入的编制程序语言,该语言不富含乌克兰语字符,仅包蕴繁体普通话字符,并保存繁体引号“”。先看看
Helloworld
怎么写:吾有一數。曰三。名之曰“甲”。為是“甲”遍。吾有一言。曰“「問天地万幸。”」。書之。云云。这段代码等效于以下
JavaScript
代码:var n = 3;for (var i = 0; i < n; i++卡塔尔国 {console.log(“問天地还好。”卡塔尔;}输出:問天地辛亏。問天地幸好。問天地万幸。同不时候,标点和换行符是完全可选的,与古中文一致,所以地点的代码等效于:吾有一數曰三名之曰“甲”為是“甲”遍吾有一言曰“「問天地辛亏”」書之云云Helloworld
看上去即使简单,但是实际作为一门编制程序语言,这里的语法都有严厉的定义:变量wenyanJavaScript吾有一數。曰三。名之曰“甲”。var
a = 3;有數三十。名之曰“大衍”。var dayan = 50;昔之“甲”者。今“大衍”是也。a
= dayan;吾有一言。曰“「噫吁戲”」。名之曰“乙”。var b =
“alas!”;吾有一爻。曰陰。名之曰“丙”。var c =
false;吾有一列。名之曰“丁”。var d =
[];吾有三數。曰一。曰三。曰五。名之曰“甲”曰“乙”曰“丙”。var
a=1,b=3,c=5;调整wenyanJavaScript若三大於二者。乃得“「想當然耳”」也。if
(3>2卡塔尔(قطر‎{ return “of course”;
}若三比异常的小於五者。乃得“「想當然耳”」。若非。乃得“「怪哉”」也。if(3<=5State of Qatar{return
“of course”}else{return “no way”}為是百遍。⋯⋯ 云云。for (var i = 0; i
< 100; i++卡塔尔{ … }恆為是。⋯⋯ 云云。while (true卡塔尔(قطر‎ { …
}凡“天地”中之“人”。⋯⋯ 云云。for (var human of worldState of Qatar{ …
}乃止。break;运算wenyanJavaScript加一以二。1+2加一於二。2+1加一以二。乘其以三。(1+2State of Qatar*3除十以三。所餘幾何。一成3減三百二十一以七百七十六。名之曰“甲”。var
a = 756-433;夫“甲”“乙”中有陽乎。a || b夫“甲”“乙”中無陰乎。a &&
b容器数组从 1
开始索引。wenyanJavaScript吾有一列。名之曰“甲”。充“甲”以四。以二。var a
= []; a.push(4,
2);銜“甲”以“乙”。以“丙”a.concat(b).concat(c);夫“甲”之一。a[0]夫“甲”之其餘。a.slice(1);夫“玫瑰”之“「名”」。rose[“name”]夫“寶劍”之長。sword.length;函数wenyanJavaScript吾有一術。名之曰“慕容剑法”。是術曰。⋯⋯是謂“参合指”之術也。function
f(卡塔尔(قطر‎{…}吾有一術。名之曰“六脈神劍”。欲行是術。必先得六數。曰“甲”。曰“乙”。曰“丙”。曰“丁”。曰“戊”。曰“己”乃行是術曰。⋯⋯是謂“六脈神劍”之術也。function
f(a,b,c,d,e,f卡塔尔{…}吾有一術。名之曰“翻倍”。欲行是術。必先得一數。曰“甲”。乃行是術曰。乘“甲”以二。名之曰“乙”。乃得“乙”。是謂“翻倍”之術也。function
double(a卡塔尔国{var b = a * 2; return
b;}不过小编表示上下文无关的语法描述还在营造中。文言语言使用自然语言管理分享了古典中文语法,将语言编写翻译为
JavaScript 或 Python,并且图灵康健。相同的时候它不只提供了一个配套在线
IDE,还提供了大气算法与数据布局示例,包蕴快排、Hanno塔难题与斐波那契数列表示等。—

栗子 晓查 发自 海边边

量子位 报道 | 公众号 QbitAI

校友,你可以见到如何用文言文输出“Hello World”?

请君睁圆双目注视于此:

左边一顿输出

作者有一言。曰「「問天地幸而。」」。書之。

却怎么输出了叁遍?

只因有for循环,写作“為是「甲」遍…云云”。甲等于三,便要问一回好。

那骚之过极的文言文编制程序语言,来自CMU本科生Huang Lingdong。

可编写翻译成Javascript,也可编写翻译成Python,亦有线上编写制定器 (IDE卡塔尔(قطر‎ 可一向玩耍。

类型文科理科两开花,已于GitHub摘得3000星,且围听大伙儿都有话说。

举个例子,妒少年之才华:

举个例子,点现在之趋向:

中国科高校计算机技术商量所钻探员刘群先生亦惊讶:

旋即,作者等便前去观膜一番,探求此语言藏有啥种天沙参华。

文言文编制程序“黑话”

Huang
Lingdong同学应该是读过《易经》,究竟易经是最初论述二进制的古籍。他用易经的代表布尔变量中的0和1。

“吾有”连串则被用来做定义:

吾有一数是定义int变量小编有一爻是定义布尔变量吾有一言是定义字符串笔者有一术是定义函数我有一列是定义数组;……

日常的编制程序里,循环推断有if、while、for,文言文编程在此件事上尤为千变万化。上边正是一段文言文书写的判定语句:

若三弗大於五者。乃得「「想當然耳」」。若非。乃得「「怪哉」」也。

翻译过来就是:

if(3=5) {return “of course”}else {return “no way”}

大概你会以为if…else…语句用文言文太啰嗦,但是常用的for循环,用文言文表达却更是简洁明了。

為是百遍。⋯⋯ 云云。

它的情趣是:

for (var i = 0; i 100; i++) { … }

假使急需看清有些变量human是或不是在world中,大家经常用for (var human of
world卡塔尔国,初读书人看来for的这种用法恐怕会很吸引,而文言文的代表更近乎平常人的接头。

凡「天地」中之「人」。⋯⋯ 云云。

古有《易经》,今有金庸(Louis-Cha卡塔尔国小说,在显示定义函数的时候,Huang同学又皮了一晃:

吾有一術。名之曰「六脈神劍」。欲行是術。必先得六數。曰「甲」。曰「乙」。曰「丙」。曰「丁」。曰「戊」。曰「己」乃行是術曰。⋯⋯是謂「六脈神劍」之術也。

这里Huang同学将函数名定义为“一阳指”,那一个函数总共有6个输入。

funcion f(a,b,c,d,e,f) {…}

再有越来越多有意思的函数定义:

何以用文言文编制程序

看完文言文编制程序的中央语法后,大家来寻访怎么用它来解决一部分主干的难点。

举个例子说求100以内的素数,大家会用到一种“埃氏筛”算法:

看一下运维结果:

二。三。五。七。一十一。一十三。一十七。一十九。二十三。二十九。三十一。三十七。四十一。四十三。四十七。五十三。五十九。六十一。六十七。七十一。七十三。七十九。八十三。八十九。九十七

您看懂是怎么着看头了啊?编写翻译器翻译成JavaScript正是:

var AI1SHI4SHAI1 = () = 0;AI1SHI4SHAI1 = function(JIA3) { var YAN3 =
[]; for (var _rand4 = 0; _rand4 JIA3; _rand4++) { (true); }; var
_ans154 = JIA3 / 2; var JIA3BAN4 = _ans154; var WU4 = 2; while (true)
{ if (WU4 == JIA3BAN4) { break; }; var XU1_ = 2; while (true) { if
(XU1_ == JIA3BAN4) { break; }; var _ans155 = WU4 * XU1_; var HE2 =
_ans155; if (HE2 = JIA3) { YAN3[HE2 – 1] = false; } else { break; };
var _ans156 = 1 + XU1_; XU1_ = _ans156; }; var _ans157 = 1 + WU4;
WU4 = _ans157; }; var ZHU1SU4 = []; var WU4 = 2; while (true) { if
(WU4 == ) { break; }; var _ans158 = YAN3[WU4 – 1]; var SU4YE2 =
_ans158; if (SU4YE2) { (WU4); }; var _ans159 = 1 + WU4; WU4 =
_ans159; }; return ZHU1SU4};var _ans160 =
AI1SHI4SHAI1(100);(_ans160);

文言文编制程序不仅能出口轻松的结果,连文字图都得以用文言文画出来,分形难题中出名的“曼德博集结”,用粤语画出来是如此:

用普通话画出的曼德博集合


您感到那就是编写翻译结果的末尾形象了?错错错!

品种文件还会有个脚本src/,它能够把程序渲染成北魏图书的旗帜。把O’Reilly体系图书印制成辽朝线装书,真是思维就很振憾啊。

设置与利用

文言文编制程序只需将repo下载到本地,何况本地曾经设置Node,就能够即刻选择。未来它扶持将wenyan
lang转变来JavaScript和Python:

./build/ examples/ -o

在这里段命令中,假设不钦定语言,程序将机关转接为JavaScript,若想转形成Python,请步入参数“—lang
py”或是“-l py”。

顾客也可以活动编写翻译二进制文件。借使您只想尝尝鲜,在线IDE也是个科学的取舍。

何出此“言”

至于,为什么要创制一门文言编制程序语言,少年为项目写有一序,由此可窥一二
(后有解读卡塔尔 :

夫唐、虞之世,結繩而足治,屈指而足算。是時豈料百代之後,計算機械之巧,精於公輸之木鳶,善於武侯之流馬;程式語言之多,繁若《天官》之星宿,奇勝《山經》之走獸。鼠、蟹、鑽、魚,或以速稱。蛇、象、駱、犀,各爭文采。方知鬼之所以夜哭,天之所以雨粟。然以文言編程者
,似所未有
。此誠非文脈之所以傳,文心之所以保。嗟予小子,遂有斯志。

然則數寸之烏絲猶覆於頭,萬卷之素書未破於手;一身長羁于远邦,兩耳久旷于雅言。然夫著小编吾之所宿好,程式者偶承時人之謬譽。故希孟不慚年少,莊生不望無涯。乃作斯言。誠未能嘔瀝長吉之心血,亦庶幾免於義山之流沫。既成之後,復學干將鑄劍而自飼,越王嚐糞而當先。自謂偶追《十書》之筆意,但恨少八家之淋漓。此子山所謂士衡抚掌而愿意,平子見陋而固宜。然則雖實覆甕之質,尚存斧正之望;雖乏呂相之金,易字之渴蓋同。此亦開源之大義,吾輩之所以勉勵也。一笑。

文中故事之多,恐无法在这里一一注释,便以划重点之法,粗粗明白其表示,并简要传达为白话:

上先人类结绳记事,不会想到后代竟然发明了计算机。今日编制程序语言众星闪耀,只是未有人用文言编制程序。我人在外国,牵挂这一个古典的说话,同期又擅长编制程序又有头发,决定为开源工作进献一份力量。

注:如想查看所有轶事,请前往项目页,出处都有维基百科链接。

量子位循马迹蛛丝,获悉少年名称为Huang
Lingdong,来自卡耐基梅隆高校,近来大四,二〇二〇年快要结束学业。高级中学生守则毕业自北京世界海外语中学。

黄姓少年一路脑洞盛放,时常开采画风清奇之项目,量子位也曾为其另一类型撰文:

任君随意涂鸦,皆可化作梦境中之剧中人物,精神矍铄,与任何人物一起玩耍游荡。如百鬼夜行之威信。

而文言文编制程序语言,大略是少年于今最佳自豪且最为瞩目之产生。

诸君可速速前往吸之,定然不也许自拔。

传送门

类型代码:

项目主页:

线上IDE试玩:

个人主页:

相关文章

No Comments, Be The First!
近期评论
    功能
    网站地图xml地图